Quantcast

bulk_copy goofiness

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bulk_copy goofiness

Raymond Lutz
Hello Foswiki friends:

I am in the middle of migrating from foswiki 1.1.9 to 2.1.2.
I've got the base system up and running (finally) and now I am turning
to converting the data.
I'm moving from RCSWrap to Plainfile, and to UTF-8.

The bulk_copy.pl utility seems to run well but one of my topics causes
it to choke, and this exposed to me behavior different from what I
thought the documentation says. I think it will need some revision to
make it as useful as it I think it is intended.

Here is the error I received and various things I tried to work around
it. Here, note that it fails when it attempts to process the topic
SoundboardAdapter in the Biofeedback web.

tools# perl bulk_copy.pl --xweb System --xweb TWiki --latest
'*.WebStatistics' /var/www/vhosts/cognisys.com/httpdocs/w119/bin
/var/www/vhosts/cognisys.com/httpdocs/w212/bin >bulk_copy.log
RCS: /usr/bin/rlog  -h %FILENAME|F% of
.../Biofeedback/SoundboardAdapter.txt,v failed:  at
/var/www/vhosts/cognisys.com/httpdocs/w119/lib/Foswiki/Store/VC/RcsWrapHandler.pm
line 363.

The topic exists in the Biofeedback web:
-rw-r--r--  1 cognisys psacln    21 Jun 28  2014 SoundBoardAdapter.lock
-rw-r--r--  1 cognisys psacln  4123 Jun 28  2014 SoundboardAdapter.txt
-rw-r--r--  1 cognisys psacln 14761 Jun 28  2014 SoundboardAdapter.txt,v

Does not look unusual. I looked at the topic and it seems innocuous. Why
it fails I do not know.
Funny that the .lock file uses different capitalization.

I noticed that if I run the SAME command again without doing anything
else, it completes the entire bulk_copy process without error BUT SKIPS
THE REST OF THE Biofeedback WEB.
Thus, the bulk_copy tool will not attempt to copy ANY files if the web
already exists.
This action makes no sense when you compare with the documentation that
says you have to take special steps to avoid copying the System web. But
since the System web already exists in the destination NO FILES WILL BE
PROCESSED NO MATTER WHAT. Same is true for Main. No topics are copied
because the web already exists in the destination.

For each subsequent try, I deleted the entire w212 install and copied it
from w212_baseinstall, so we start fresh each time.

Looking into this, I deleted the .lock files.  This also failed the same
way.
If I skip just that topic:

perl bulk_copy.pl --xweb System --xweb TWiki --xtopic SoundboardAdapter
--latest '*.WebStatistics'
/var/www/vhosts/cognisys.com/httpdocs/w119/bin
/var/www/vhosts/cognisys.com/httpdocs/w212/bin >bulk_copy.log

It completes. But the completed data is missing that topic.

Tried again, using  "--latest SoundboardAdapter" in the command. That fails.
Tried again, deleting all history for Soundboard Adapter (deleted
SoundboardAdapter.txt,v) -- Same failure.

So I went ahead with the conversion of the data without that topic by
using --xtopic SoundboardAdapter

I wanted to try to convert ONLY THAT ONE FILE.
I thought that MAYBE I could specify --itopic SoundboardAdapter and
bulk_copy would ONLY try to copy that topic.
NO! Nothing is done because the Biofeedback web already exists.

--> I was hoping that I could use the same tool to incrementally convert
one topic at a time, thereby gradually building the result.
--> the option --itopic is nearly worthless because only will work if
the web does not exist at all.
--> All the hoopla about System does not match apparent operation.
System will never be copied even if you say --iweb System, because it
already exists.

I did not attempt to modify the code because I wanted to run this by the
list to make sure I am thinking correctly about this.
--Ray







------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
Foswiki-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/foswiki-discuss
Loading...